Jump to content

C20Xe Rough Idling


Recommended Posts

The C20XE on my Manta starts ok but has a rough idle.  I've now fitted new plugs (do you need to set the gap on the GM plugs with the 2 electrodes on the sides?), leads, rotor arm and dizzy cap but it's still the same. 

 

Any suggestions?

Thanks

Link to post
Share on other sites

Possibly idle valve common problem.

Remove the pipe from your inlet cap spray either carb cleaner or a bit of wd down leave for a while refit pipe see if better.

Same idle valve on some saabs or many opel variants.

Sutty had same issue last mionth

  • Like 1
Link to post
Share on other sites
  • 2 weeks later...

Idle control valves are a pain in the back side. Ive got 3, all of them make the engine run different. And they are hard to get out if its still under the manifold. I tried to relocate mine to behind the power cap but need to have steel hose as the original isnt strong enough.

Link to post
Share on other sites

Thanks for the replies, I can't start it at the moment as I'm wiring in the alarm/immobiliser. 

It's still located under the manifold at the moment, hadn't thought of moving it.

Does this only affect the revs at idle when the car is cold?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...