Jump to content

Fuel Injection problem - LE Jetronic - Fixed :-)


Recommended Posts

Bought an 2.0 ’85 hatch but it failed on the way home...

It will still start and run really roughly while holding a button that is apparently connected to the fuel pump & 5th injector.

The AA man reckons its the Airflow Meter but didn’t want to say 100% (and that’s fair enough). He also said the mixture screw was far too easily adjusted and those seals should be tight?

Should I try anything else? 

If not, can these things be refurbished or is it a case of taking a deep breath and ordering this?




Edited by Trooker
Link to comment
Share on other sites

Hi there.sorry to hear of your troubles.

this depends on exactly what you mean when you say it “failed” on the way home.!

are we talking completely cut out ,flooded,choked itself rich,loss of power etc.exactly what we’re the symptoms ?

also there is no “button” that does what you describe unless I’m mistaken so the breakdown guy may be having you on there a bit !

it may well be the airflow meter that’s faulty ,who knows but I would suggest that you start with the basics first before swapping any major parts unless you know of a nearby member who will let you try some parts. There are lots of things that can go wrong and it could be any one or more of those or something realy simple.

Link to comment
Share on other sites

I should have given more context.

The car was running fine when we left the guys house. 5 Mins away was a petrol station so I took the opportunity to fill it up with fuel, it took around £40 of super unleaded and we headed off.

The fuel gauge only registered a little over 1/2 full, the oil pressure gauge was bouncing off the max, voltage gauge a bit low and the temp gauge a bit high. I’ll order a new voltage regulator to sort that.

Anyway, I took it fairly easy on the motorway and sat mainly in the slow lane at HGV speed. After about 20 mins we pulled into a service station, bought some snacks, had a good look around for leaks, checked the oil etc, had a quick look to try & see why the exhaust is very occasionally knocking on the floor at low revs and put air in one tyre, let some out of another. Headed out again, accelerated fine out of the slip road and all seemed great.

Later, when I lost power I dipped the clutch to coast off the road & the ignition light came on, I tried letting out the clutch a couple of times to see if she’d go again before rolling to a stop.

There really is a non-latching button on the fuse box cover that a previous owner has wired-in which is apparently connected to the 5th injector for cold starting. I guess there has been a historical issue with a sensor that should make it work automatically. I tried that button while cranking and presumably as the engine was at temp and despite the mixture being garbage it started and ran badly, I could coax it up to around 3000rpm but let go that button and it dies within a few seconds so I knew that the ignition etc was still ok.

I don’t see anything melted but note that some of the wires for the injectors weren’t hooked up on the proper bracket and therefore a bit too close to the exhaust manifold. I’m starting to wonder if, rather than a metering head failure, the longer run and slow-cook has been a bit much on ancient wiring.

The car has been recovered now so I’ll have another poke around and see what I can discover.

Thanks for the response :-)

Link to comment
Share on other sites

Are you getting petrol while cranking engine? Flow is into injector loop, and return is after pressure regulator.

Maybe pump is messing about. Its a push pump,  2L pop bottle, If its a hatch, check vents on tank, Search here 2p trick! These are basic cars, easy to work on etc etc.

Keep this updated, 

Could be pump, or injection relay, try fuse 7, make sure its clean and tight

Link to comment
Share on other sites

Removed filler cap.

Fuse 7 clean, no oxidisation. 

Found 2p trick with picture here

 shorted base of fuses 7 & 8, could hear the fuel pump go but she didn't start.

Pressing and holding that button she'll start & run really, really lumpy, still died when letting it go. Fuel pump still running though so removed coin.

Sorry, I don't understand 2L pop bottle, should I be taking a fuel-line off and measuring the amount pumped through over a set time? 

thanks again!







Link to comment
Share on other sites

If it isn't running from cold or hot i would be checking the connection to the ECU (the plugs can come loose etc), I would also be taking no notice of AA people as the mixture screw comment sounds total BS! i would also check to see if the fuel is flowing to the rail. If these check out i would be thinking coil, earth or temp sensor.

Link to comment
Share on other sites

I'd also be very interested in the modification made and the button you mention. What is this connected to and where?

But as for your comment a lot of the GTE looms are becoming hard and brittle and you may well be correct. But that is very easy to check with the wiring diagram and a multi-meter.

You can buy every sensor new for the GTE injection system except for the thermotime switch. But check what you have before you purchase anything.

Link to comment
Share on other sites

7 hours ago, MrCarlos said:

Ecu fault or the multi plug to it as danny says. Or also possible is the ecu mounting screws - the ecu earths through them and if they are loose or rusty the car would behave as you describe

Sorry but I need to correct this. The ecu does not earth through the case on a GTE.

The earth point is attached to the back of the inlet manifold with a ring connector and is secured with 6mm? bolt.

Link to comment
Share on other sites

Finally got half an hour to get under the bonnet!

Really appreciate all the comments & suggestions.

Snowy, the button mounted on the fuse cover has one end connected to a 12V supply, the other goes through the bulkhead and directly to the cold start injector. The other wire from that injector is grounded. There are 3 white wires on the injection loom that have been cut and are taped up. I'm assuming these are the original wires to the cold start injector.

I've sprayed some servisol contact cleaner on the the connections to the meter head and ecu. Given that the cold start injector can give enough fuel to get her started, I'm fairly convinced that the ignition system and the fuel pump & relay are all ok.

I just tried disconnecting the metering head & starting with the button. She starts exactly the same with it disconnected... 

Off to dig a little deeper :-)



Edited by Trooker
Noobie error mixed up terms - metering head connection is NOT ecu -_-
Link to comment
Share on other sites

Tried shorting out the terminals but no change. I took the relay innards out of the housing and managed to observe it while tying to start.

The relay closes when the turning the key & the engine cranks, it releases when I stop cranking. It gives a second click a second or so after trying, presumably to prime the system.

I then tried with the cold start injector energised and she started & ran as before. The relay remained closed as long as the engine was running. De-energising the cold start injector and the engine stopped, the relay opened & then gave a momentary close and open again. 

Will poke around with a multimeter some more. 


Just to confirm, with the relay apart I've monitored 12V on pins 87 & 30 when closing the relay manually. I can hear the fuel running through the lines too.

Edited by Trooker
Link to comment
Share on other sites

13 hours ago, MrCarlos said:

Nope it earths through the casing as well.

Simple test - if you unscrew a gte ecu from the car bodywork the car wont run

Screw it back on securely it will run

Mine runs quite fine not screwed to the bodywork.

I have tried it several times.

Link to comment
Share on other sites

Took the covers off a couple of bits




It seems as if the Burgess microswitch should be activated when the accelerator is not being pressed, the unit wasn't lined up very well & so it was never pressed. Easy to tweak it with the cover off. Both that and the leaf switch work fine. 


On closer inspection the silicone mastic holding down the plastic cover for the potentiometer on the Air flow meter said it had all been apart before so why not have a look




I was hoping that the various connections were poor and that would be it but really it all looked quite decent.

I also checked each contact to the PCB when the plug was back in place. The wiper makes a good connection at each end, I ran out of hands & a lack of crocodile clips meant detailed checks mid track wasn't happening in the failing daylight.

There doesn't seem to be any 12V getting here though, at least not with the ignition on. I'll have to make a temporary mod to extend the manual switch on the cold-start injector so I can do further voltage tests under the bonnet with the engine running.


Edited by Trooker
Link to comment
Share on other sites

Try not to alter anything inside the airflow meter if at all possible. You dont know if anyone has tampered with it but they may not have just because there are signs the cover has been off. Also you should be able to turn the throttle switch on its mountings to make the contacts close unless someone has been in and bent them before you. It should be adjusted so that the contacts open as soon as the throttle starts to move and then register full throttle as well.

the fact that the engine runs(in a fashion) when you operate the 5th injector proves that you have ignition and fuel flow but points to a problem with the injectors not firing by either not having power or a fault with the ecu.

it could also be not firing due to a massive air leak such as a servo hose off or other large bore hose.

these cars can have issues with water ingress into the footwells and damaging the ecu .

if holding the main relay contacts manually closed, or linkingthe contacts,does not help and checking the main earth connection to the inlet manifold is good then no action or even trying to fire a bit does sound like the injectors are not being fired.a maladjusted airflow meter or throttle switch,would not prevent it even trying.its also unlikely for all the injectors to fail.

the haynes book does have a good wiring diag so if you are ok with a meter it would be worth checking voltages are where thry should be otherwise gte ecu's are cheap and plentifull to try if everything else checks out ok.

are there any local members willing to bring you one or try yours in their car ?

Link to comment
Share on other sites

Since the car was running fairly well when I picked it up and did so for nearly 70 miles I'm not keen on adjusting anything. I'm of the opinion that this is either a bad connection or a component failure.

The look inside the metering head was to check the connections. I also realise the adjustment the AA man made on that unit was simply to the screw that adjusts the air bypassing the metering flap for idle.

The throttle switch was a little misaligned but is in the right position now. Again I was trying to prove connections of plugs etc.

Having carried out a load of searches last night and found other info online I think I need to prove if a trigger from the hall effect switch on the distributor is getting to the ecu. I'm getting my head around the injection system now and it isn't actually that complicated after all.

I'll have to buy a Haynes book!

I'm new to the club and don't know if there are any members anywhere nearby. I've liked the Manta since they were new but as a kid couldn't afford one! I've read through various projects on the forum every now and then for probably a decade but circumstances made buying one a bit daft so I'd get on with other stuff in life and forget it again. I haven't met anyone in the club face to face and we all know how the internet can throw up mad characters as well as the genuine people so I'm rather reticent to ask as a newbie. I'd post my ecu to one of the long term known guru's if they were willing to test it but I'll carry on checks around the car for now.

I'm unlikely to get much time on it for the next 10 days so updates will slow down.



Edited by Trooker
Link to comment
Share on other sites

  • Trooker changed the title to Fuel Injection problem - LE Jetronic

If i recall the green lt coil wire goes to pin 1 of the ecu as well as the tacho. You should be able to find the wiring diag on google images but yes i agree with your statement that if it drove home part way fine then its not a major failure or maladjustment or wired up wrong etc etc .something has happened/ gone faulty that is stopping the injectors firing.

and also i agree this is quite a basic injection system and relatively easy to understand..nice to see that you are working out how it works as thats the best way in my opinion to fault find anything.

look forward to your findings 

Link to comment
Share on other sites

  • 2 weeks later...

Got another ecu and she lives again!

The tweaks at the roadside meant that initially she was revving up to 2000 or so rpm & falling back every few seconds. I realised the stop on the end of the throttle was screwed out quite a way, eased that down, played with the air-bypass allen screw on the metering head and she's idling steady at around 900 rpm. 

Thanks again for all the comments and suggestions, I've learned a lot over the past couple of weeks :-)

Now thinking I should learn about replacing the very tired looking vacuum servo & master cylinder but that'll have to be another thread.


Edited by Trooker
  • Like 1
Link to comment
Share on other sites

  • Trooker changed the title to Fuel Injection problem - LE Jetronic - Fixed :-)

Great news glad it’s sorted.

out of curiosity and to check i would open up the old broken ecu and check for any signs of water ingress.they can get water leaks down the side of the footwell area from a variety of places and it would be a shame to damage another ecu.worth a good check down in the footwell for any evidence,wet carpet rust stains ,holes etc.

any signs of water/rusty marks etc. And I would be checking corner of windscreen seal and up inside the inner wing and washer bottle area.most of our cars will be showing some level of rust in these areas by now .also as a precaution anyway it is always worth looping a plastic sheet over the top and around the front/back of the ecu.they were originally covered this way albeit not quite well enough.

happy tinkering

  • Like 1
Link to comment
Share on other sites

  • 2 months later...

Hi everyone - so first time on here having purchased my Manta 4 days ago (its my third one but the first two were in 1991 (old Y reg) and 1992 my dads 4 year old Manta Exclusive that I bought off the lease company!  


Unfortunately I think I might have the same problem as above - do the symptoms sound the same?  Car idles perfectly and for about the first 30 mins works like a dream but then if coughs and splutters and i can bairly limp home (1 call to the AA at midnight later and I spluttered home rather than wait an hour and half!

So far I have replaced the fuel pump, fuel filter, petrol breather hose, air filter, full service, temperature sensor and the non existent thermostat and no joy

The petrol is milky and I have added some additive to allow it to flush through if there is a bit of water in it (the previous owner not having driven it for some time) but I would not see why that would cause a problem 30 minutes in

The temperature gauge is off the rails although having done an actual temperature check it is fine so I know I probably need to replace or adjust the voltage regulator but does that do anything to affect the running other than the dials?

There is no voltage at the engine coolant temperature sensor or at the one at the end of the inlet manifold

Any suggestions - should I try the ECU next or....

Any suggestions much appreciated as its now gone beyond my skill set!

Many thanks and hello!


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...