Jump to content

plumbing in a Megsasquirt MS1


Recommended Posts

hi,

I've finally plumbed in my MS1 v1 I've had sitting in my garage since 2006, and will be setting it up on Saturday via the latest TunerStudio MS which now I've registered; question: how do I connect the tacho MS lead to the Manta? looking around the engine, there's no obvious place.

Link to post
Share on other sites

further to:

because my MS1 is so old it wont talk to tunerstudio without updating the firmware-which I'm having trouble doing;

question: can I do a straight swap with an MS2 unit? are the pin outs the same, as my DB37 connector sensor tails are all plumbed in? Megasquirt UK is doing:

MS 2 V 3 Extra Code fully assembled, 2.5 bar MAP sensor, 2.5 Bar MAP sensor, good for normally aspirated or Boosted Engines to 30psi max, and fitted with 2 coil drivers so will run a 4 cycl wasted spark, this is the recommended way as you have complete control of the timing and can also use the onboard rev limiting facility, + your Fuel Injection, comes with a resonable MAP to get you up and running, wiring diagram you can download from this site (Link), DB37 Plug, and DB9 cable to connect to your pc, Price £475.00 + and Shipping + VAT

which I'll buy provided I can do a straight swap.

  • Like 1
Link to post
Share on other sites
  • 2 weeks later...

Jess,

I ended buying an MS2 V3 from Phil, as the MS1 proved to be too old to update; we chatted via email and he convinced me to go for the MS2-alomg with a buch of documentation.

i'll be installing it this Saturday, weather permitting.

  • Like 1
Link to post
Share on other sites
2 hours ago, execman said:

Jess,

I ended buying an MS2 V3 from Phil, as the MS1 proved to be too old to update; we chatted via email and he convinced me to go for the MS2-alomg with a buch of documentation.

i'll be installing it this Saturday, weather permitting.

Had the same sort of experience with mine. Had a webcon system that had been in the cupboard for years, got it on and just running, but loads of issues so ended up with new Omex 600, hooked it up, started first time 🙂

Also the guys could remote connect and tweak it for me!

Andy

Link to post
Share on other sites
2 hours ago, execman said:

Jess,

I ended buying an MS2 V3 from Phil, as the MS1 proved to be too old to update; we chatted via email and he convinced me to go for the MS2-alomg with a buch of documentation.

i'll be installing it this Saturday, weather permitting.

Fair play mate, I have mine bench built and find the connection solid, but not got close to the engine loom yet!
keep us updated for sure 👍

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...