Jump to content

Mk 1 cavalier gls coupe


Kurtupsin75
 Share

Recommended Posts

Link to comment
Share on other sites

Link to comment
Share on other sites

  • 3 weeks later...
2 minutes ago, Kurtupsin75 said:

Cavalier clocked up 80 miles trouble free so far not hundred percent running correctly but it getting there .

Great to hear you’re on the road👍

How did you sort the weeping brake fluid issue, did you replace or get new seals?

  • Like 1
Link to comment
Share on other sites

10 hours ago, Trooker said:

Great to hear you’re on the road👍

How did you sort the weeping brake fluid issue, did you replace or get new seals?

I dismantled a old one and the seals was in great shape but still weeps a tiny bit 

Just now, Kurtupsin75 said:

I dismantled a old one and the seals was in great shape but still weeps a tiny bit 

All the seal in new ones had gone hard and broke in to pieces hence it leaked 

Link to comment
Share on other sites

14 hours ago, Kurtupsin75 said:

I dismantled a old one and the seals was in great shape but still weeps a tiny bit 

All the seal in new ones had gone hard and broke in to pieces hence it leaked 

That’s a pain with the New Old Stock, I wonder if the slightly weeping old seals will soften a bit with fluid & be ok in the long run. 
 

Anyway, fantastic job on the Cav, I hope to see it in the coming months 👍

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   1 member

×
×
  • Create New...