Jump to content

AlecHowie

OMOC Members
  • Content Count

    7
  • Joined

  • Last visited

Community Reputation

0 Neutral

About AlecHowie

  • Rank
    Kadett

Profile Information

  • Location
    Scotland
  • Name
    Alec Howie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hello Me again! Manta 1.8s previous problem was top hose, bottom hose cold & radiator cold temp rising. So, new thermostat fitted got top hose heating and radiator. While at it checked timing belt and water pump and all as new. Put back together and ran in garage, all warmed and temp sat in the middle of scale for fair length of time so all seemed good, temp went up a bit thermostat opened temp fell back. All good. Heat from heater but just warm. Taxed the car and off we went, ok for 6 miles or so ,,,temp rising slightly over normal. Checked under bonnet and bottom hose cold. Heater hoses hot, top hose and radiator top hot but not overly so, System had pressure so cap working .Drove back and temp sat just over normal and just under the next white mark,... never went past that and not near Red. Home 12 miles now and bottom hose still cold. Squeezed it with rad cap off and water did "burp" so rad not blocked. and had flushed it and put new antifreeze in. Thought air lock but cant clear it. Still think it is and air lock - ideas? Is there a knack to bleeding air out? I ran it topping up radiator as we filled it, squeezed bottom pipe,.... Any advice welcome, Im certainly getting good value from membership! Work tomorrow but intend to have another crack at it on Friday Cheers Alec
×
×
  • Create New...